summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoruvok cheetah2024-09-12 20:53:47 +0200
committeruvok cheetah2024-09-12 20:53:47 +0200
commitcf0265c7a1e29482efd6bc3c3717fb43160683cc (patch)
treeec40c4df681b1eeb720006dc63a41ef02b82ba77
parent7d8f36bfdf1553a38fcadf5e3b2fae64f727c558 (diff)
Add patch file for libcurl
-rw-r--r--patches/curl-force-use-cacert.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/patches/curl-force-use-cacert.patch b/patches/curl-force-use-cacert.patch
new file mode 100644
index 0000000..bf49ad8
--- /dev/null
+++ b/patches/curl-force-use-cacert.patch
@@ -0,0 +1,18 @@
+Patch buildroots libcurl makefile, so it uses the cacert bundle.
+
+Assumes ca-certificates is selected. (Manual!)
+
+--- a/package/libcurl/libcurl.mk 2024-09-11 20:35:52.369995331 +0200
++++ b/package/libcurl/libcurl.mk 2024-09-08 20:40:51.393654807 +0200
+@@ -83,10 +83,11 @@
+ LIBCURL_CONF_OPTS += --without-gnutls
+ endif
+
+ ifeq ($(BR2_PACKAGE_LIBCURL_MBEDTLS),y)
+ LIBCURL_CONF_OPTS += --with-mbedtls=$(STAGING_DIR)/usr
++LIBCURL_CONF_OPTS += --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
+ LIBCURL_DEPENDENCIES += mbedtls
+ else
+ LIBCURL_CONF_OPTS += --without-mbedtls
+ endif
+