summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Config.in1
-rw-r--r--package/w3m/Config.in8
-rw-r--r--package/w3m/w3m.mk18
3 files changed, 27 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index 53475f1..ddbffb6 100644
--- a/Config.in
+++ b/Config.in
@@ -1,2 +1,3 @@
comment "uvok's packages"
source "$BR2_EXTERNAL_UVOK_BUILDROOT_PATH/package/rpi-utils/Config.in"
+source "$BR2_EXTERNAL_UVOK_BUILDROOT_PATH/package/w3m/Config.in"
diff --git a/package/w3m/Config.in b/package/w3m/Config.in
new file mode 100644
index 0000000..0b3a78b
--- /dev/null
+++ b/package/w3m/Config.in
@@ -0,0 +1,8 @@
+# dependencies taken from rpi-userland
+
+config BR2_PACKAGE_W3M
+ bool "w3m"
+ help
+ w3m, the command line browser by Debian.
+
+ https://salsa.debian.org/debian/w3m
diff --git a/package/w3m/w3m.mk b/package/w3m/w3m.mk
new file mode 100644
index 0000000..98ff195
--- /dev/null
+++ b/package/w3m/w3m.mk
@@ -0,0 +1,18 @@
+################################################################################
+#
+# w3m
+#
+################################################################################
+
+W3M_VERSION = ee66aabc3987000c2851bce6ade4dcbb0b037d81
+W3M_SITE = $(call gitlab,debian,w3m,$(W3M_VERSION))
+W3M_LICENSE = W3M-License
+#W3M_LICENSE_FILES = LICENCE
+#W3M_INSTALL_STAGING = YES
+
+#define W3M_POST_TARGET_CLEANUP
+# rm -Rf $(TARGET_DIR)/usr/src
+#endef
+#W3M_POST_INSTALL_TARGET_HOOKS += W3M_POST_TARGET_CLEANUP
+
+$(eval $(autotools-package))