summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/rpi-utils/0001-only-vcgencmd.patch3
-rw-r--r--package/rpi-utils/Config.in4
-rw-r--r--package/rpi-utils/rpi-utils.mk8
3 files changed, 8 insertions, 7 deletions
diff --git a/package/rpi-utils/0001-only-vcgencmd.patch b/package/rpi-utils/0001-only-vcgencmd.patch
index 0f7c970..2240b40 100644
--- a/package/rpi-utils/0001-only-vcgencmd.patch
+++ b/package/rpi-utils/0001-only-vcgencmd.patch
@@ -1,3 +1,6 @@
+Author note: I am only interested in vcgencmd. Other tools
+may or not compile (uvok).
+
--- a/CMakeLists.txt 2024-09-09 19:39:12.297119443 +0200
+++ b/CMakeLists.txt 2024-09-09 19:39:24.145109420 +0200
@@ -2,14 +2,4 @@
diff --git a/package/rpi-utils/Config.in b/package/rpi-utils/Config.in
index 5a14b4c..d2339c5 100644
--- a/package/rpi-utils/Config.in
+++ b/package/rpi-utils/Config.in
@@ -1,3 +1,5 @@
+# dependencies taken from rpi-userland
+
config BR2_PACKAGE_RPI_UTILS
bool "rpi-utils"
depends on BR2_arm || BR2_aarch64
@@ -11,6 +13,8 @@ config BR2_PACKAGE_RPI_UTILS
help
https://github.com/raspberrypi/utils
+# taken from rpi-userland
+
comment "rpi-utils needs a toolchain w/ C++, threads, dynamic library"
depends on BR2_arm || BR2_aarch64
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS || \
diff --git a/package/rpi-utils/rpi-utils.mk b/package/rpi-utils/rpi-utils.mk
index d26ff27..abe1e25 100644
--- a/package/rpi-utils/rpi-utils.mk
+++ b/package/rpi-utils/rpi-utils.mk
@@ -1,6 +1,6 @@
################################################################################
#
-# rpi-userland
+# rpi-utils
#
################################################################################
@@ -10,12 +10,6 @@ RPI_UTILS_LICENSE = BSD-3-Clause
RPI_UTILS_LICENSE_FILES = LICENCE
RPI_UTILS_INSTALL_STAGING = YES
-ifeq ($(BR2_aarch64),y)
-RPI_UTILS_CONF_OPTS += -DARM64=ON
-endif
-
-RPI_UTILS_CONF_OPTS += -DALL_APPS=OFF
-
define RPI_UTILS_POST_TARGET_CLEANUP
rm -Rf $(TARGET_DIR)/usr/src
endef