summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/rpi-utils/0001-only-vcgencmd.patch17
-rw-r--r--package/rpi-utils/Config.in17
-rw-r--r--package/rpi-utils/rpi-utils.hash3
-rw-r--r--package/rpi-utils/rpi-utils.mk24
4 files changed, 61 insertions, 0 deletions
diff --git a/package/rpi-utils/0001-only-vcgencmd.patch b/package/rpi-utils/0001-only-vcgencmd.patch
new file mode 100644
index 0000000..0f7c970
--- /dev/null
+++ b/package/rpi-utils/0001-only-vcgencmd.patch
@@ -0,0 +1,17 @@
+--- a/CMakeLists.txt 2024-09-09 19:39:12.297119443 +0200
++++ b/CMakeLists.txt 2024-09-09 19:39:24.145109420 +0200
+@@ -2,14 +2,4 @@
+
+ project(utils)
+
+-# List of subsidiary CMakeLists
+-add_subdirectory(dtmerge)
+-add_subdirectory(eeptools)
+-add_subdirectory(otpset)
+-add_subdirectory(overlaycheck)
+-add_subdirectory(ovmerge)
+-add_subdirectory(pinctrl)
+-add_subdirectory(raspinfo)
+ add_subdirectory(vcgencmd)
+-add_subdirectory(vclog)
+-add_subdirectory(vcmailbox)
diff --git a/package/rpi-utils/Config.in b/package/rpi-utils/Config.in
new file mode 100644
index 0000000..5a14b4c
--- /dev/null
+++ b/package/rpi-utils/Config.in
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_RPI_UTILS
+ bool "rpi-utils"
+ depends on BR2_arm || BR2_aarch64
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on !BR2_STATIC_LIBS
+ select BR2_PACKAGE_HAS_LIBEGL if BR2_arm
+ select BR2_PACKAGE_HAS_LIBGLES if BR2_arm
+ select BR2_PACKAGE_HAS_LIBOPENVG if BR2_arm
+ select BR2_PACKAGE_HAS_LIBOPENMAX if BR2_arm
+ help
+ https://github.com/raspberrypi/utils
+
+comment "rpi-utils needs a toolchain w/ C++, threads, dynamic library"
+ depends on BR2_arm || BR2_aarch64
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS || \
+ BR2_STATIC_LIBS
diff --git a/package/rpi-utils/rpi-utils.hash b/package/rpi-utils/rpi-utils.hash
new file mode 100644
index 0000000..e4854ba
--- /dev/null
+++ b/package/rpi-utils/rpi-utils.hash
@@ -0,0 +1,3 @@
+# Locally computed
+sha256 0db20b7dfb24849a13ae457ccabbc1c88a02d6a0528ae6354ce66d26be150491 rpi-utils-d4f8fb543a892ba65bfc608511bf582c0425aa81.tar.gz
+sha256 bee6f1249175683d8610651706e1aa7dffcbfd3f9c4c05bc1e5ab34f313c2db5 LICENCE
diff --git a/package/rpi-utils/rpi-utils.mk b/package/rpi-utils/rpi-utils.mk
new file mode 100644
index 0000000..d26ff27
--- /dev/null
+++ b/package/rpi-utils/rpi-utils.mk
@@ -0,0 +1,24 @@
+################################################################################
+#
+# rpi-userland
+#
+################################################################################
+
+RPI_UTILS_VERSION = d4f8fb543a892ba65bfc608511bf582c0425aa81
+RPI_UTILS_SITE = $(call github,raspberrypi,utils,$(RPI_UTILS_VERSION))
+RPI_UTILS_LICENSE = BSD-3-Clause
+RPI_UTILS_LICENSE_FILES = LICENCE
+RPI_UTILS_INSTALL_STAGING = YES
+
+ifeq ($(BR2_aarch64),y)
+RPI_UTILS_CONF_OPTS += -DARM64=ON
+endif
+
+RPI_UTILS_CONF_OPTS += -DALL_APPS=OFF
+
+define RPI_UTILS_POST_TARGET_CLEANUP
+ rm -Rf $(TARGET_DIR)/usr/src
+endef
+RPI_UTILS_POST_INSTALL_TARGET_HOOKS += RPI_UTILS_POST_TARGET_CLEANUP
+
+$(eval $(cmake-package))